一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月15日

CVE-2026-77147 [MEDIUM] – Improper Control of Generation of Code (‘Code Injection’) vulnerability in Apache Syncope.

未分类
📑 文章目录

Improper Control of Generation of Code (‘Code Injection’) vulnerability in Apache Syncope.

An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.