一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月4日

CVE-2026-62183 [CRITICAL] – Improper Privilege Management vulnerability in Apache Syncope. When: * the all-Java user

未分类
📑 文章目录

Improper Privilege Management vulnerability in Apache Syncope.

When:

* the all-Java user workflow adapter is configured, or
* the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests

the following scenario could happen.
A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.

Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.