一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月4日

CVE-2026-53405 [CRITICAL] – Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administra

未分类
📑 文章目录

Improper Isolation or Compartmentalization vulnerability in Apache Syncope.

An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a Groovy scriptTask is imported and started, the Groovy script is executed directly on the server, with no sandbox.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.

Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by wrapping Flowable’s Groovy scriptTasks with security sandbox.