一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月4日

CVE-2026-76208 [HIGH] – phpMyFAQ versions 3.1.0 through 4.1.6 contain an authentication bypass vulnerability in Au

未分类
📑 文章目录

phpMyFAQ versions 3.1.0 through 4.1.6 contain an authentication bypass vulnerability in AuthLdap::create(). When LDAP authentication is enabled, after a successful LDAP bind the code calls User::setStatus(‘active’) unconditionally, which overwrites the account_status column of a pre-existing local account from ‘blocked’ to ‘active’. As a result, a user whose local phpMyFAQ account has been administratively blocked can restore their account and log in by authenticating via LDAP. The state transition is not logged, so administrators cannot detect that the block was overridden. Fixed in 4.1.7.