一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月4日

CVE-2026-49284 [HIGH] – SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prio

未分类
📑 文章目录

SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prior to 2.4.7 and 2.5.2, SimpleSAMLphp’s SAML SP ACS path does not enforce the IdP selected for an SP-initiated login when unsigned Response/InResponseTo is combined with a signed assertion lacking SubjectConfirmationData/InResponseTo, allowing a response issued by one trusted IdP to be bound to SP state created for another IdP and bypass flows that route users to a specific IdP, including deployments that set enable_unsolicited to false. This issue is fixed in versions 2.4.7 and 2.5.2.