一线运维实战手记 · 云计算 · 数据库 · 故障排查
2026年9月4日

CVE-2022-51000 [CRITICAL] – Nokogiri before 1.13.2 (CRuby, when using packaged libraries) ships vendored libxml2 2.9.1

未分类
📑 文章目录

Nokogiri before 1.13.2 (CRuby, when using packaged libraries) ships vendored libxml2 2.9.12 and libxslt 1.1.34, which are affected by two upstream CVEs. Via CVE-2021-30560 in libxslt, an application transforming XML with untrusted XSL stylesheets is vulnerable to a denial-of-service attack. Via CVE-2022-23308 in libxml2, an application parsing an untrusted document with parse option DTDVALID set to true and NOENT set to false may be vulnerable to denial of service, memory disclosure, or code execution. Nokogiri 1.13.2 upgrades vendored libxml2 to 2.9.13 and libxslt to 1.1.35.